Board index Peugeot RCZ Peugeot RCZ General Pairing Issue

Pairing Issue

General Community Discussion - Anything RCZ

Post Tue Jun 19, 2018 5:04 pm
marcrcz Newbie
Newbie

Posts: 1
Kudos: 0
I have just bough a RCZ (love it) but i have to pair my phone everytime i get in!!!!!!


Post Tue Jun 19, 2018 5:09 pm
2retro User avatar

Senior Member
Senior Member

Posts: 1150
Kudos: 514
Hi and welcome to the forum!

It does that sometimes with me too. When it happens I find completely disconnecting/deleting the paired equipment from both car and device then pairing again sorts it (until it happens again...). :thumbup:

Post Tue Jun 19, 2018 5:42 pm
RCZIain Moderator
Moderator

Posts: 579
Kudos: 157
Location: Lincolnshire
What radio do you have?
I've never had any issues pairing with my NG4.

Sent from my VFD 710 using Tapatalk
Image
Sandra, 2011 200 GT. Shark grey, Ulter Quad exhaust. Vision pack.

Post Tue Jun 19, 2018 6:32 pm
DKZ5745 User avatar

Senior Member
Senior Member

Posts: 3579
Kudos: 1069
Location: Yorkshire
Paired mine 5 years ago, works every time I get in - RT6 (a bit of a lie actually, I swapped my iPhone 6 for an iPhone X when they came out & had to pair that one, but you get the gist).
Mk 2 GT200 Moroccan Red

Post Wed Jun 20, 2018 1:03 am
Plecodoras User avatar

Senior Member
Senior Member

Posts: 1080
Kudos: 510
Location: North Yorks
Me too had no issues with any of the Z's RT6 and NG4, though NG4 did take it's time to connect - sometimes.
:lol: Laugh and the whole world laughs with you.... or is that at you? :eusa-think:


Return to Peugeot RCZ General