Board index Peugeot RCZ Newbies Missfireing

Missfireing

Introduce yourself to the forum here. What do you drive and what have you ordered?

Post Sat Feb 18, 2017 9:27 am
Rossi46 Newbie
Newbie

Posts: 3
Kudos: 0
Hi I've only joined this morning! I've purchased a Z200 in white love it had 1 before but a 156!
How ever the dreaded engine fault light came on! Whilst ticking over it revs smoothly & effortless however when driving you have to hardly press the throttle to keep it running smooth! Press the accelerator inch or so straight into misfire and if you lift off quickly it's back to normal! Hold it on misfire it stays on 3 until it's turned off! Fan is on once it's missfireing!! Frustrated I reved it off the limiter no problem but won't pull when it's on load! No matter what revs it's when you push the throttle down it plays up! No over heating still good on fuel just hoping it's not pump or tensioner problems! Cool or plug hopefully only started yesterday! Pls help much appreciated


Post Sat Feb 18, 2017 10:02 am
DKZ5745 User avatar

Senior Member
Senior Member

Posts: 3591
Kudos: 1077
Location: Yorkshire
:greetings-wavingblue: Welcome :text-welcomewave:

Sorry you are having issues with your Z. You have already touched on the 2 more likely causes, High pressure fuel pump, or even more likely timing chain tensioner.

If you get the fault code, it will probably help, as there are people on here that can tell you exactly what it refers to. If it is the chain, I don't think there is much you can do, other than get the kit replaced, or at the very least the tensioners.

Hope you get it sorted soon, as the 200 is an awesome car that needs to be given a sound thrashing once in a while :D
Mk 2 GT200 Moroccan Red

Post Sun Feb 19, 2017 9:34 am
Rossi46 Newbie
Newbie

Posts: 3
Kudos: 0
Hi I've had few error codes
P1338
P1336
P1340
P1030
It's driving fine until you ask for more fuel & boost drive like miss daisy you wouldn't no there's anything wrong! Engine very quite no rattling on chain at all! Just turned to 53.180 miles now! Thanks for reply

Post Sun Feb 19, 2017 10:20 am
Sanity Senior Member
Senior Member

Posts: 175
Kudos: 43
P1336= Combustion misfiring on unspecified cylinders fault: Not characterised
P1338 = Misfiring fault on cylinders 2
P1340 = Misfiring fault on cylinders 4

P1030 is a fault in the variable valve lift system coherance.
You can read more about it if you search for it on this forums. Can be serious issues or if lucky nothing at all.

I'd leave it to peugeot for further looks.

Post Sun Feb 19, 2017 10:25 am
DKZ5745 User avatar

Senior Member
Senior Member

Posts: 3591
Kudos: 1077
Location: Yorkshire
That does sound more like a fuel delivery problem, which would point to the high pressure fuel pump. The timing chain would give you some audible feedback if it was the issue.

I don't have access to the OBDII codes, so not sure what they refer to, but I'm sure someone else reading this thread will come along with more comprehensive information regarding them.

There is also the possibility of coil issues, I'm not 100% sure if that would give the same symptoms, but I know people have had problems with coil packs failing, so you could also bear that in mind.
Mk 2 GT200 Moroccan Red

Post Sun Feb 19, 2017 10:27 am
DKZ5745 User avatar

Senior Member
Senior Member

Posts: 3591
Kudos: 1077
Location: Yorkshire
Ahhh, there you go, I knew someone would help out with the codes, must have been typing at the same time as me.
Mk 2 GT200 Moroccan Red

Post Mon Feb 20, 2017 3:29 am
drdino Senior Member
Senior Member

Posts: 131
Kudos: 15
Coil pack(s) and/or plugs are very likely the cause. Can you get a readout of the short and long term fuel trims, along with the fuel rail pressure?

Post Mon Feb 20, 2017 7:31 pm
Rossi46 Newbie
Newbie

Posts: 3
Kudos: 0
Hi thanks for comments! However tonight whilst leaving work almost home i bounced it off the limiter 3/4 times with the clutch down once loaded up its back! Just hope it is packs or plugs! Fuel rail pressure is that a Peugeot job to get the pressure?

Post Tue Feb 21, 2017 4:52 am
drdino Senior Member
Senior Member

Posts: 131
Kudos: 15
Not necessarily, I use a Bluetooth dongle with an app on my phone to get a readout.

Post Fri Jan 12, 2018 10:07 pm
joemac2803 Newbie
Newbie

Posts: 2
Kudos: 0
Rossi

I have exactly the same issue , have been trying to sort for 3 months now replaced spark plugs and ignition coils and still same issues.

Did you get yours fixed.

Thanks

Post Thu Mar 01, 2018 8:33 am
RAFALEZ Newbie
Newbie

Posts: 1
Kudos: 0
Same problem atm, when reset fault and I stay in charge from 50 bar to 120 bars pressurein the fuel ramp ok, as soon as I live the trottle the next accel is misfiring etc.
P1336 P1340 P1338 sometimes P0087
when I look to freezed data when trouble occure looks like the fuel pressure in the ramp is under 10bar
RCZ 2011 156 THP auto shifter

Already changed the fuel high pressure pump 20.000 km back atm 120.000km

need to see if the fuel link before the hight pressure is good also the low pressure pump in the tank perhaps. what to you think experts ?
thanks in advance

Post Thu Mar 01, 2018 2:15 pm
DKZ5745 User avatar

Senior Member
Senior Member

Posts: 3591
Kudos: 1077
Location: Yorkshire
RAFALEZ wrote:
Same problem atm, when reset fault and I stay in charge from 50 bar to 120 bars pressurein the fuel ramp ok, as soon as I live the trottle the next accel is misfiring etc.
P1336 P1340 P1338 sometimes P0087
when I look to freezed data when trouble occure looks like the fuel pressure in the ramp is under 10bar
RCZ 2011 156 THP auto shifter

Already changed the fuel high pressure pump 20.000 km back atm 120.000km

need to see if the fuel link before the hight pressure is good also the low pressure pump in the tank perhaps. what to you think experts ?
thanks in advance


Have you replaced the coils? This seems to be a more common cause than the HP fuel pump for this issue.
Mk 2 GT200 Moroccan Red


Return to Newbies