Board index Peugeot RCZ Peugeot RCZ Technical Discussion Exterior Wiper blades

Wiper blades

Body panels, spoiler, wipers, mirrors and windows, feline pack etc

Post Sat Jul 09, 2016 8:51 am
KRU User avatar

Newbie
Newbie

Posts: 3
Kudos: 0
I need new wiper blades, as I can't see in the rain! I'm looking at Eurocarparts - does anyone know the difference between the Bosch ones at £30 or the standard 26" ones at £8. Is there really such a big difference in performance?
2011 GT Automatic - Black/Silver arches - Glasgow


Post Sat Jul 09, 2016 2:43 pm
The biff Newbie
Newbie

Posts: 4
Kudos: 3
Yeah .... More expensive wipers like Bosch or peugeot use a better quality rubber that 1..cleans/wipes better and 2.. Don't Feffing squeal. . Remember 99 percent of your driving involves looking through front screen so keep clean

Post Sat Jul 09, 2016 2:45 pm
drdino Senior Member
Senior Member

Posts: 124
Kudos: 14
Best ones I've used are the Valeo or SWF ones.

Post Sat Jul 09, 2016 5:10 pm
DKZ5745 User avatar

Senior Member
Senior Member

Posts: 3093
Kudos: 854
Location: Yorkshire
Thing is as well, it's not like it's a very regular replacement, so it's worth paying a bit more for top quality :eusa-think:
Mk 2 GT200 Moroccan Red

Post Wed Jul 27, 2016 7:23 am
Dencole Regular
Regular

Posts: 24
Kudos: 7
Location: Burnham, Essex
Hi Guys
I had to buy some new wiper blades. I opted for the Bosch for £30 from Eurocarparts. Anyway for some reason I can't get them to click in to place. They go on the arm most of the way but that last little bit just does not want to click in to place. What am I missing/doing wrong? Please help...
Thank You
Love my RCZ

Post Wed Jul 27, 2016 9:30 am
DKZ5745 User avatar

Senior Member
Senior Member

Posts: 3093
Kudos: 854
Location: Yorkshire
Might sound stupid, but have you put them on the correct arms. The fitting for the drivers side is a bit different for the fitting on the passenger side.
I bought my replacement blades from Peugeot. They incorrecty marked the boxes as near side & offside (found out later it's a French thing - other way round to us).
So I fitted one - went on fine, the other went on mostly, but wouldn't click into its locked position. I tried for ages & eventually went back to my dealership, where they couldn't get it to fit either & were going to order in another blade when a mechanic said swap them round, so we did & both went on fine.

Just a thought anyway :eusa-think:
Mk 2 GT200 Moroccan Red

Post Sat Sep 10, 2016 6:56 pm
Kgouloumis09 User avatar

Member
Member

Posts: 56
Kudos: 11
Lol,had the same issue with mine and thought I bought the wrong blade,try putting them in at an angle then line it up straight before you click them in.
They will go on after 15mins of fiddling around for the first time.


Sent from my iPhone using Tapatalk


Return to Exterior