Board index Peugeot RCZ Peugeot RCZ Technical Discussion Ipods, MP3 Players and Sat Nav One day electrical glitch ?

One day electrical glitch ?

Inc Phone connectivity, radio and other media

Post Thu Aug 18, 2016 10:53 pm
DKZ5745 User avatar

Senior Member
Senior Member

Posts: 3729
Kudos: 1129
Location: Yorkshire
So, a couple of days ago, started the car as normal, nav screen rolled open, displayed phone contacts synchro message as normal, but then, message came up saying phone call was in progress.
I couldn't get the message to go, even turned my phone off & back on, so I had to turn the car off & back on then the message went away, but screen showed 0 satellites visible & indicated I was in the middle of a field. I had this part of the problem once before & had a new GPS aerial fitted which sorted the problem, so I thought it couldn't really be that. The issue continued almost all the way through my journey,(@10 miles) then just before I parked up, it suddenly found 4 satellites & displayed my correct location on the map.

Also, I noticed that my headlights were on, even though it was a sunny day. Turning the headlights off & then back to auto didn't solve this. Eventually I turned the headlights to "on" then all the way to off then back to auto & they went out.

When I got back in the car it was dark, but when I opened the car on the remote, the headlights didn't come on, and they always do if it's dark. They did come in when I started the car, but I had the 0 Satellites visible thing again for @ 5 miles, then it found 5 & worked fine the rest of the journey home.

I have had no issues since, no fault messages, or anything recorded in the log. The car runs out of manufacturers warranty in a few weeks, & also goes in for its 3rd service around that time. I was wondering whether to mention this, so it's down as having happened prior to the warranty expiring, but I know that there is little chance of them even trying to do anything, as there is currently no fault.

I was just wondering if anyone has ever had anything like this with their Z & if so, what did it turn out to be ? If in fact you ever discovered that.
Mk 2 GT200 Moroccan Red


Post Fri Aug 19, 2016 1:04 pm
tianorth User avatar

Senior Member
Senior Member

Posts: 1781
Kudos: 372
Location: Fareham, Hampshire
Report it to your dealership and make sure they record it with Peugeot as an intermittent fault.

Then if it shows up again after warranty has run out you have should still have a claim.
Tia2 is a 2013 RCZ Magnetic in Black with a 2litre diesel engine
Upgraded Peugeot sat-nav now has 7 digit postcode, safety alerts and updated maps
Other mods include door catch covers, rcz puddle lights, quad exhaust tips
Tia3 is a 2015 RCZ-R in Mercury Grey with a 1.6litre petrol engine, oh and 270 bhp
Other mods include door catch covers, rcz puddle lights
Both have dash cams front and back

Post Fri Aug 19, 2016 1:20 pm
DKZ5745 User avatar

Senior Member
Senior Member

Posts: 3729
Kudos: 1129
Location: Yorkshire
Yeah, cheers Chris, that's what I thought.
I have already mentioned a couple of minor issues, just in case they develop, so I think it's worth telling them about this too.

Really odd events though, and seemingly not related to each other. Very strange. :eusa-think:
Mk 2 GT200 Moroccan Red

Post Fri Aug 19, 2016 2:35 pm
tianorth User avatar

Senior Member
Senior Member

Posts: 1781
Kudos: 372
Location: Fareham, Hampshire
My diesel had an electrical glitch the other week in that the screen opened as normal but nothing came on it, I drove for a very short time and stopped and switched off, but then put on the ignition again and all worked properly, not done it since.
Tia2 is a 2013 RCZ Magnetic in Black with a 2litre diesel engine
Upgraded Peugeot sat-nav now has 7 digit postcode, safety alerts and updated maps
Other mods include door catch covers, rcz puddle lights, quad exhaust tips
Tia3 is a 2015 RCZ-R in Mercury Grey with a 1.6litre petrol engine, oh and 270 bhp
Other mods include door catch covers, rcz puddle lights
Both have dash cams front and back

Post Fri Aug 19, 2016 3:24 pm
RCZ_123 Member
Member

Posts: 56
Kudos: 10
Could always try the magical BSI reset?

Post Fri Aug 19, 2016 11:10 pm
DKZ5745 User avatar

Senior Member
Senior Member

Posts: 3729
Kudos: 1129
Location: Yorkshire
I'd thought about that, but as it's all working ok again, I wouldn't know if it had done anything or not :crazy:

In the past, sometimes when I've started the car, the screen opens & starts up almost instantly. Other times, it can take 30 seconds or so, maybe even a bit more.

It has never bothered me, as it's always worked fine, up to the other day.

I will mention it when it goes in on the 6th & it might even give me a bit of a bargaining chip when they try to sell me the extended warranty. :eusa-think:
Mk 2 GT200 Moroccan Red

Post Tue Aug 23, 2016 8:45 am
RCZ_123 Member
Member

Posts: 56
Kudos: 10
Worth a shout!

Could also be a glitch in the firmware if the sat nav has been updated recently?

Post Tue Aug 23, 2016 1:44 pm
DKZ5745 User avatar

Senior Member
Senior Member

Posts: 3729
Kudos: 1129
Location: Yorkshire
Maps & alert zones have been updated, firmware is already latest. I suppose it might have been the maps or speed cam updates, but it its odd that it didn't do it straight after the update, which was a few weeks previous.

It's going in in a couple of weeks anyway, so I'll keep an eye on it til then, & tell them about it when it goes in, when they try & sell me an extended warranty.
Mk 2 GT200 Moroccan Red

Post Tue Aug 23, 2016 3:58 pm
tianorth User avatar

Senior Member
Senior Member

Posts: 1781
Kudos: 372
Location: Fareham, Hampshire
Mine has had the same maps and risk alerts updates, no problem with mine!
Tia2 is a 2013 RCZ Magnetic in Black with a 2litre diesel engine
Upgraded Peugeot sat-nav now has 7 digit postcode, safety alerts and updated maps
Other mods include door catch covers, rcz puddle lights, quad exhaust tips
Tia3 is a 2015 RCZ-R in Mercury Grey with a 1.6litre petrol engine, oh and 270 bhp
Other mods include door catch covers, rcz puddle lights
Both have dash cams front and back

Post Tue Aug 23, 2016 4:24 pm
RCZ1 User avatar

Senior Member
Senior Member

Posts: 9533
Kudos: 1481
Location: East Riding of Yorkshire
My Sat Nav recently stopped working. Didn't know the roads I was driving (showed me driving in the river) and when I set the Nav, it thought I was somewhere completely different. This happened on a number of days over the last feed weeks. I should point out I did the Risk Alert update at the end of July and it had done this once before then. Since the update it did it on several occasions. However, over the last week the Sat Nav appears to know where I am and the directions have been working as normal.
Mk 2 Sport 156 Moroccan Red Bespoke Nappa leather
Black Roof Arches Sports Pack Sat Nav K&N Filter Philips Diamond Vision lights


RCZ Sport 156 in Pearl White Bespoke Nappa leather interior with RCZ motif
K & N High Performance Air Filter 360/60 LED DRLs Phillips Extreme +100% Headlights Custom Car Mats

Post Tue Sep 06, 2016 3:19 pm
DKZ5745 User avatar

Senior Member
Senior Member

Posts: 3729
Kudos: 1129
Location: Yorkshire
So, the car is in for its 3rd service today as part of a service plan I took out when I bought the car.

Everything is covered of course, so nothing extra to pay, well, er, except for the brake fluid change, that's not covered (@£45) and the engine flush, that's not covered (£don't know yet). Oh & we mentioned the MOT when you took the service plan out, but in fact it doesn't cover that either, but you do get it discounted to £30.

I asked if there was any updates advised by Peugeot for my car. The guy said he had no idea what I was talking about. I mentioned that some members of the forum had been told of an ECU software update, and he said that they would never check for any updates unless the owner complained of a fault with the car.

The service assistant told me that manufacturers hate forums. He said they miss inform people about "common faults" that aren't common, and about updates, that aren't updates at all.

I told him about several issues that had been experienced by many members of the forum and he said that he hadn't come across any of them. EVEN TIMING CHAIN TENSIONERS !!! He reckoned that they weren't a problem on the RCZ.

I don't hold out much hope for the "bobble" I keep hearing at low speeds that I told them to investigate, or for the noise I get quite regularly from the front left brake when moving off from standstill, or for the one off electrical glitch I had the other week.

I can only hope that they manage to do the MOT & service without actually breaking anything.

#panickingalittlebit #bettergetmycardout
Mk 2 GT200 Moroccan Red

Post Tue Sep 06, 2016 5:01 pm
2retro User avatar

Senior Member
Senior Member

Posts: 1192
Kudos: 532
DKZ5745 wrote:
The service assistant told me that manufacturers hate forums. He said they miss inform people about "common faults" that aren't common, and about updates, that aren't updates at all.

I told him about several issues that had been experienced by many members of the forum and he said that he hadn't come across any of them. EVEN TIMING CHAIN TENSIONERS !!! He reckoned that they weren't a problem on the RCZ.

Brilliant! :crazy: :helpme:

Post Tue Sep 06, 2016 6:15 pm
DKZ5745 User avatar

Senior Member
Senior Member

Posts: 3729
Kudos: 1129
Location: Yorkshire
So, got the car back. It does seem to brake better now, everything else seems as it was when it went in.

Total charge for my "free" service £105. :crazy:

As for my reported intermittent faults,
"groaning" noise from front left after being stationary with foot on brakes -
Nothing found.
"Bobbling" noise at low speeds over uneven ground -
Nothing found.
"One day electrical glitch" -
Nothing found.

The ignorant guy I spoke to over the phone was at the desk when we went in, sat us down, got the paperwork out, then handed us over to a woman as soon as she appeared & he walked off without saying a word to us.

I don't think he likes forums :eusa-think:
Mk 2 GT200 Moroccan Red

Post Tue Sep 06, 2016 8:32 pm
tianorth User avatar

Senior Member
Senior Member

Posts: 1781
Kudos: 372
Location: Fareham, Hampshire
Wonder if the technicians know what's on the forums, they might be able to diagnose problems correctly
Tia2 is a 2013 RCZ Magnetic in Black with a 2litre diesel engine
Upgraded Peugeot sat-nav now has 7 digit postcode, safety alerts and updated maps
Other mods include door catch covers, rcz puddle lights, quad exhaust tips
Tia3 is a 2015 RCZ-R in Mercury Grey with a 1.6litre petrol engine, oh and 270 bhp
Other mods include door catch covers, rcz puddle lights
Both have dash cams front and back

Post Tue Sep 06, 2016 8:48 pm
renegade79 User avatar

Senior Member
Senior Member

Posts: 1848
Kudos: 373
Location: Ireland
Not great customer service there! Your dealer stinks of incompetence! :eusa-whistle:
308GTi THP270 in magnetic blue


RCZ gone but not forgotten

Post Tue Sep 06, 2016 9:11 pm
DKZ5745 User avatar

Senior Member
Senior Member

Posts: 3729
Kudos: 1129
Location: Yorkshire
It's a shame that people can't be more open minded. Just because it's not written in a memo from Peugeot, doesn't mean that a group of owners can't actually be right about certain issues that have been collectively experienced.

F1 engineers & mechanics are the best of the best, does that mean they don't listen to their drivers when they tell them something isn't quite right?

Anyway, cars back, looks as good as ever, drives brilliantly & hopefully doesn't need to go back to the nasty garage people for another 12 months.

So I might just have to put up with the odd groan from the front brakes, a bit of bobbling never hurt anyone & if the electrics decide to take one day a year off, we all need a break don't we :eusa-whistle:
Mk 2 GT200 Moroccan Red

Post Sun Jan 22, 2017 11:09 pm
Perkybillet User avatar

Senior Member
Senior Member

Posts: 449
Kudos: 139
RCZ1 wrote:
My Sat Nav recently stopped working. Didn't know the roads I was driving (showed me driving in the river) and when I set the Nav, it thought I was somewhere completely different. This happened on a number of days over the last feed weeks. I should point out I did the Risk Alert update at the end of July and it had done this once before then. Since the update it did it on several occasions. However, over the last week the Sat Nav appears to know where I am and the directions have been working as normal.

Mine does that sometimes, usually when I've been in a underground car park and I also worked out that some dash cams can interfere with the sat nav. It would appear the receiver is just behind where the rear view mirror is [SMILING FACE WITH OPEN MOUTH]


Sent from my iPhone using Tapatalk
Nera Black GT 2.0 HDi
Integral Light Grey Lama/Mistral Leather
Black Pack & Black badges
Debadged
Vision Pack
JBL HiFi Pack
19 inch Sortilege Black Alloys
Zunsport Quads
Sat Nav - RT6
On-Board Wifi Unit
Driving Assistant
16 litre Isotherm
Peugeot Protect
Boot Tray


Return to Ipods, MP3 Players and Sat Nav