Board index Peugeot RCZ Peugeot RCZ Technical Discussion Interior Air Con Blower Not Working

Air Con Blower Not Working

Leather, seats, dash, aircon, heaters & strange noises

Post Mon Dec 30, 2013 8:53 am
AlfaNige Regular
Regular

Posts: 11
Kudos: 0
Hi all, I've looked around on here but can't find any clues

The blower has stopped working on the car, the F11 40A fuse is OK in the under bonnet fuse box, I've looked in the handbook for anything related, but couldnt find anything.

The panel itself is working OK, all the buttons do what they should, but the blower simply isn't working, no matter what position, function etc. Nothing else appears to be amiss.

The unit was working fine until I parked it up a week or so ago.


Post Mon Dec 30, 2013 8:58 am
Abzynthe User avatar

Moderator
Moderator

Posts: 3795
Kudos: 1019
Location: Peterborough

Have you twisted the knob in the middle to set it to maximum? If I have mine on auto from cold the fans dont kick in until the car is up to temperature.

Post Mon Dec 30, 2013 9:52 am
AlfaNige Regular
Regular

Posts: 11
Kudos: 0
Yep, did that, but also this happened a couple of days ago and the car has been driven too.

However........... we have some good flooding down here this morning and I hit one at pace, aquaplaned for a bit, hit dry land and the blower burst into life!

Just think its having one of its moody times as it does from time to time. Worse than any Alfa I have ever had lol!

Post Mon Dec 30, 2013 10:07 am
TomC User avatar

Senior Member
Senior Member

Posts: 612
Kudos: 320
I think a blower which doesn't blow sucks.
Tom

The blackest THP 200 of all...

Post Mon Dec 30, 2013 11:53 am
stevebasshead User avatar

Senior Member
Senior Member

Posts: 763
Kudos: 325
Location: UK
I had this after being parked up for a week or 10 days or so. It started working again a couple of days later (on the very day I had it booked in to the garage for investigation, typical!)

The diagnosis was that the battery charge had dropped so the car automatically shut down non essential systems and once I'd driven it a bit the charge level came back up hence why it started working. The garage changed my battery under warranty because it want holding it's charge.

Hope this helps.

Sent from my SM-N9005 using Tapatalk

Post Mon Dec 30, 2013 1:48 pm
AlfaNige Regular
Regular

Posts: 11
Kudos: 0
That sounds like it could be why then lol! It was the only thing that didn't work. The misses drove it (its her car after all lol!) on Saturday and "forgot" to tell me, then I drove it last night and found it not working. On the way to Exeter it all sprang into life after my surfing escapade.

If this is the cause its good to see that Peugeot think demisting the car isn't essential but the heated seats are, along with the ultra annoying auto windscreen wipers and even more annoying auto mirror dip when you go into reverse as all that billhooks was working last night - as was its tendency to see a ghost that I am about to reverse into and have a div about that - it did that last night as well again haha!

Post Mon Dec 30, 2013 2:42 pm
bigmac3161 User avatar

Senior Member
Senior Member

Posts: 2455
Kudos: 737
Location: Northern Ireland
If u put the mirror switch/button in the middle they don't dip ;)
PURE WHITE VOLKSWAGEN GOLF R
BORN JULY HOPEFULLY
18" CADIS ALLOYS

Post Mon Dec 30, 2013 3:33 pm
Abzynthe User avatar

Moderator
Moderator

Posts: 3795
Kudos: 1019
Location: Peterborough

One of the warranty receipts for my car says the reverse sensors were replaced due to them saying there was something there. Ive never had that so it obviously did the trick :)

Post Mon Dec 30, 2013 5:07 pm
stevebasshead User avatar

Senior Member
Senior Member

Posts: 763
Kudos: 325
Location: UK
Yes, it's a bit of a flaw in the design that it switches the whole air con system off including the basic blowers, demisting should always be available IMHO.

My reversing sensors glitched out once but only when they were caked in muck, a quick wipe and they were Ok again.

Sent from my SM-N9005 using Tapatalk

Post Mon Dec 30, 2013 7:05 pm
AlfaNige Regular
Regular

Posts: 11
Kudos: 0
Well, the car strikes again....

The central dash display has now gone completely and the dashboard is now all in Metric, i.e. l/km and km!

Fecking piece of Gallic crap!!!

Post Mon Dec 30, 2013 7:24 pm
Abzynthe User avatar

Moderator
Moderator

Posts: 3795
Kudos: 1019
Location: Peterborough

Sounds like it could all be related.

Its either bad earth, dead battery or fried BSI :shock:

Post Mon Dec 30, 2013 7:42 pm
AlfaNige Regular
Regular

Posts: 11
Kudos: 0
I'd rather not think it is a bad earth on a car such as this, thats the sort of thing I get on my old Alfa's or Subaru's!

I dont think the body computer is at fault, it wouldnt revert to KM it would either work or not, rather than intermittently.

I just get the feeling its given a gallic shrug and in a blast of garlic breath said "je ne donne pas une merde" so I am going to crawl back under a Freelander and do another IRD unit for the fun of it...

Post Sat Jan 10, 2015 10:17 am
jeremy31 Newbie
Newbie

Posts: 1
Kudos: 0
I've got mine booked in for next Friday to investigate what reads like exactly the same problem. All the fan lights working fine but no fan. Just wondered did the problem disappear completely or has it reoccurred. Just wondering if I cancel my booking and see if it fixes itself. Find a nice deep puddle to drive through <grin>
Regards
Jeremy

Post Wed Apr 08, 2015 9:13 pm
renegade79 User avatar

Senior Member
Senior Member

Posts: 1613
Kudos: 305
Location: Ireland
my air con has packed in now. the switches light up fine as normal but i cannot hear the fan kicking in. i've checked and switched the fuse but no joy. i wonder is it the battery like whats been reported here. the fact that the fan is not working suggest an electrical fault though. has anyone else had a similar fault and how was it fixed?
RCZ GT HDi 163
19" Onyx Black Solstice alloys
Zunsport Quad Exhausts
LED's all round
Finally space in the boot for 2 Transatlantic suitcases!


RCZ gone but not forgotten
Currently in a 208 GTi in Rioja Red

Post Thu Apr 09, 2015 8:44 pm
renegade79 User avatar

Senior Member
Senior Member

Posts: 1613
Kudos: 305
Location: Ireland
Bump
RCZ GT HDi 163
19" Onyx Black Solstice alloys
Zunsport Quad Exhausts
LED's all round
Finally space in the boot for 2 Transatlantic suitcases!


RCZ gone but not forgotten
Currently in a 208 GTi in Rioja Red

Post Tue Apr 21, 2015 4:01 pm
renegade79 User avatar

Senior Member
Senior Member

Posts: 1613
Kudos: 305
Location: Ireland
Anyone got a part number for a 2011 2.0hdi air conditioning radiator? Mine has a hole in it and the stealer wants criminal money for a new one!!!!
RCZ GT HDi 163
19" Onyx Black Solstice alloys
Zunsport Quad Exhausts
LED's all round
Finally space in the boot for 2 Transatlantic suitcases!


RCZ gone but not forgotten
Currently in a 208 GTi in Rioja Red

Post Tue Apr 21, 2015 10:16 pm
tianorth User avatar

Senior Member
Senior Member

Posts: 1455
Kudos: 295
Location: Fareham, Hampshire
Image

Is this what you after?

This is listed as an rcz hdi. So I think it's the same for all years.
Tia2 is a 2013 RCZ Magnetic in Black with a 2litre diesel engine
Upgraded Peugeot sat-nav now has 7 digit postcode, safety alerts and updated maps
Other mods include door catch covers, rcz puddle lights, quad exhaust tips
Tia3 is a 2015 RCZ-R in Mercury Grey with a 1.6litre petrol engine, oh and 270 bhp
Other mods include door catch covers, rcz puddle lights
Both have dash cams front and back

Post Tue Apr 21, 2015 10:38 pm
renegade79 User avatar

Senior Member
Senior Member

Posts: 1613
Kudos: 305
Location: Ireland
Yes that's the one! Thanks Tianorth. I've managed to source one from UK for one third of the price that the Cowboys were charging me here!!!
RCZ GT HDi 163
19" Onyx Black Solstice alloys
Zunsport Quad Exhausts
LED's all round
Finally space in the boot for 2 Transatlantic suitcases!


RCZ gone but not forgotten
Currently in a 208 GTi in Rioja Red

Post Sat Apr 25, 2015 8:15 am
frankvdb User avatar

Senior Member
Senior Member

Posts: 488
Kudos: 75
Location: Eindhoven (The Netherlands)
renegade79 wrote:
Yes that's the one! Thanks Tianorth. I've managed to source one from UK for one third of the price that the Cowboys were charging me here!!!


Are you sure that it's the same part?
Some brands have been saving on the material used for the "mesh" and the cheaper ones are very brittle so you're more likely to get a leak.
Does it say what material it uses?
My car history:
2010 Peugeot RCZ HDi 163hp blue tuanake full options
2001 Peugeot 307 3-door XSi HDi 110hp blue recife
1995 Peugeot 306 3-door XNd 70hp rouge analou

Post Sat Apr 25, 2015 2:47 pm
renegade79 User avatar

Senior Member
Senior Member

Posts: 1613
Kudos: 305
Location: Ireland
:thumbdown: Yikes, now you have me worried. I'm not even sure if this is a genuine part. It still hasn't arrived yet. fingers crossed its a good one!
RCZ GT HDi 163
19" Onyx Black Solstice alloys
Zunsport Quad Exhausts
LED's all round
Finally space in the boot for 2 Transatlantic suitcases!


RCZ gone but not forgotten
Currently in a 208 GTi in Rioja Red

Next

Return to Interior