Board index Peugeot RCZ Peugeot RCZ Technical Discussion Drivetrain Engine fault light on !!!

Engine fault light on !!!

Engine, gearbox, exhaust and other drivetrain issues

Post Sun Feb 18, 2018 7:22 pm
braveheart Member
Member

Posts: 78
Kudos: 23
Hi all my engine fault light has come on today and car went into limp mode.
As I pulled up outside my home and stopped the fan kept running after I switched the engine off.
Anyone had this issue before ?


Post Sun Feb 18, 2018 7:46 pm
DKZ5745 User avatar

Senior Member
Senior Member

Posts: 3648
Kudos: 1098
Location: Yorkshire
I think these symptoms have been linked to a couple of issues, but I think the most common being a coil pack failing.
If you can get a fault code & do a search on here, you will undoubtedly find the exact issue, without the fault code, you won’t know which coil pack is causing problems.

It might be worth noting also that people who have experienced this issue have gone on to replace all the coils, as it seems that when one goes, the others tend not to be far behind.
Mk 2 GT200 Moroccan Red

Post Sun Feb 18, 2018 8:18 pm
braveheart Member
Member

Posts: 78
Kudos: 23
Thx mate il need to get a code reader tomoz as ive no idea what code it is ?

Post Sun Feb 18, 2018 9:52 pm
RCZIain Moderator
Moderator

Posts: 641
Kudos: 187
Location: Lincolnshire
You'll want planet, generic code readers don't work well with Peugeots.

Sent from my VFD 710 using Tapatalk
Image
Sandra, 2011 200 GT. Shark grey, Ulter Quad exhaust, Vision pack, jbl and Nav.

Post Sun Feb 18, 2018 11:03 pm
braveheart Member
Member

Posts: 78
Kudos: 23
RCZIain wrote:
You'll want planet, generic code readers don't work well with Peugeots.

Sent from my VFD 710 using Tapatalk

Could you expand on that plz still a newbie at this :thumbup:

Post Mon Feb 19, 2018 12:06 am
RCZIain Moderator
Moderator

Posts: 641
Kudos: 187
Location: Lincolnshire
Peugeot planet software, interface and a laptop. Generic code readers from my experience are cack. They give you a code, sometimes, and that's about it.

Sent from my VFD 710 using Tapatalk
Image
Sandra, 2011 200 GT. Shark grey, Ulter Quad exhaust, Vision pack, jbl and Nav.

Post Mon Feb 19, 2018 7:16 pm
braveheart Member
Member

Posts: 78
Kudos: 23
Quick update started up this morning and fault was gone !! took her a spin and no probs so far , code reader brought up p0172 mix too rich and p1338 misfire on cylinder 2, I had put in some petrol that I don't normally use (cheap stuff) don't know if that had anything to do with it ?? But obvs happy she's back to normal

Post Mon Feb 19, 2018 8:28 pm
RCZIain Moderator
Moderator

Posts: 641
Kudos: 187
Location: Lincolnshire
Don't want to piss on your chips but I bet if it's got a fault it will come back.

Sent from my VFD 710 using Tapatalk
Image
Sandra, 2011 200 GT. Shark grey, Ulter Quad exhaust, Vision pack, jbl and Nav.

Post Mon Feb 19, 2018 8:45 pm
braveheart Member
Member

Posts: 78
Kudos: 23
RCZIain wrote:
Don't want to piss on your chips but I bet if it's got a fault it will come back.

Sent from my VFD 710 using Tapatalk
Haha thx for the positive attitude I will be changing coils and spark plugs tomoz

Sent from my SM-G930F using Tapatalk

Post Mon Feb 19, 2018 8:56 pm
RCZIain Moderator
Moderator

Posts: 641
Kudos: 187
Location: Lincolnshire
Coil packs won't fix the fuelling issue.
It could be the maf, but I'd assume that would ping a code or show up in live data.

I'd check the fuel delivery pressure.

Sent from my VFD 710 using Tapatalk
Image
Sandra, 2011 200 GT. Shark grey, Ulter Quad exhaust, Vision pack, jbl and Nav.

Post Mon Feb 19, 2018 10:51 pm
DKZ5745 User avatar

Senior Member
Senior Member

Posts: 3648
Kudos: 1098
Location: Yorkshire
When I mentioned that it could be a couple of things, coil packs being the most common, one of the other issues that has thrown up similar symptoms is the high pressure fuel pump.

Hopefully, the coil packs will sort it.
Mk 2 GT200 Moroccan Red

Post Wed Feb 21, 2018 12:39 pm
pgregory Regular
Regular

Posts: 16
Kudos: 1
i had this very same symptom on my asphalt a few weeks ago
fans stayed on so long they flattened the battery

it was coil pack 2 they replaced and then reset the code


Return to Drivetrain

cron